姬長信(Redy)

xml-如何从同一程序集的多个版本配置Unity?


我有多个版本的程序集,每个版本都实现一个称为RequestHandler的类型(带有IRequestHandler).

我想使用“ v1.1”或“ v1.2”之类的别名来配置每个可用的版本.

在运行时,使用别名以正确版本处理请求,以创建程序集正确版本的实例.

这需要配置驱动.我不知道如何配置Unity来实现这一目标?有任何想法吗?