姬長信(Redy)

java – 在maven依赖项中显示省略的版本:t…


Eclipse中,当我转到Maven Dependency Hierarchy页面时,我得到输出,指出导致版本被忽略的冲突:

但是,如果我使用dependency:tree,那就省略了,我只看到实际使用的evrsions:

|  +- commons-httpclient:commons-httpclient:jar:3.1:compile
|  +- commons-codec:commons-codec:jar:1.4:compile
|  +- commons-io:commons-io:jar:2.4:compile
|  +- commons-net:commons-net:jar:3.1:compile
|  +- javax.servlet:servlet-api:jar:2.5:compile

后来实际引用的版本……

+- commons-collections:commons-collections:jar:3.1:compile

有没有办法获得依赖:树输出省略冲突的版本?

谢谢!