姬長信(Redy)

Eclipse:jdk7的错误错误


我一直遇到日食问题,这给我带来了太多压力.每当我开始一个新的Java项目时,一切都顺利而完美,直到我“清理”项目(项目 – >清洁…),一切都进入@#?%& …
我一直在:

> XYZ无法解析为某种类型
>源级别低于1.7时,不允许使用多捕获参数
>运算符不允许源级别低于1.7

这非常好,只是我导入了所有必需的类,而且自从begginig以来我确实有1.7.这是我安装的唯一版本.我已经尝试了过去几天的this和其他类似的回复,但没有用.
一个解决方案是创建一个新项目,复制并粘贴所有包/ clases,这已经工作了一段时间,但我将UMLet添加到项目中并再次…删除UMLet插件对我没有任何作用.

顺便说一句,即使有“错误”,我的项目也没有任何问题,因此我知道它们并不真实.我可以继续工作,但是,当我发现真正的错误时,我无法看到……
有没有人有最终的解决方案摆脱这种错误的错误?

编辑:
我忘了提到我正在和开普勒合作.

编辑2:

以下是包含所请求信息的屏幕截图.